aboutsummaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
...
* [PATCH 37/57] ls: simplfy handling of parametersLeah Rowe2022-06-242-26/+25
|
* [PATCH 35/57] add note about cat to todoLeah Rowe2022-06-241-0/+1
|
* [PATCH 34/57] Rename LICENSE to COPYINGLeah Rowe2022-06-242-189/+674
| | | | | | | | | Also: re-download the same license text (GPLv3), but formatted to 80 characters max per line. Taken from here: https://www.gnu.org/licenses/gpl-3.0.txt
* [PATCH 32/57] date: removed unused argc/argv from main()Leah Rowe2022-06-241-7/+1
|
* [PATCH 31/57] update the .gitignore fileLeah Rowe2022-06-241-3/+6
|
* [PATCH 30/57] centralized MakefileLeah Rowe2022-06-2414-226/+70
|
* [PATCH 29/57] head: re-factor some codeLeah Rowe2022-06-242-25/+23
|
* [PATCH 28/57] update TODOLeah Rowe2022-06-241-0/+1
|
* [PATCH 27/57] yes: remove unnecessary includeLeah Rowe2022-06-241-1/+0
|
* [PATCH 26/57] cat: remove unnecessary includeLeah Rowe2022-06-241-1/+0
|
* [PATCH 25/57] date: clean up some codeLeah Rowe2022-06-241-10/+7
|
* [PATCH 24/57] create a dedicated TODO list, in a fileLeah Rowe2022-06-246-25/+7
|
* [PATCH 23/57] head: re-factor the codeLeah Rowe2022-06-241-10/+6
|
* [PATCH 22/57] cat: re-factor the codeLeah Rowe2022-06-241-29/+22
|
* [PATCH 21/57] cat: use unbuffered printfLeah Rowe2022-06-241-11/+8
|
* [PATCH 20/57] date: re-factor, and use unbuffered printfLeah Rowe2022-06-241-8/+7
|
* [PATCH 19/57] head: use unbuffered printfLeah Rowe2022-06-241-0/+2
|
* [PATCH 18/57] yes: re-factor, and use unbuffered printfLeah Rowe2022-06-241-21/+9
|
* [PATCH 17/57] ls: use printf, unbufferedLeah Rowe2022-06-241-19/+16
| | | | As opposed to the currently defined "print" function.
* [PATCH 16/57] ls: fix wrong check for -aLeah Rowe2022-06-241-1/+1
|
* [PATCH 15/57] ls: further de-bloat the codeLeah Rowe2022-06-241-26/+9
|
* [PATCH 14/57] ls: actually initialize params[6] in main()Leah Rowe2022-06-241-3/+3
|
* [PATCH 13/57] ls: Further simplify the codeLeah Rowe2022-06-241-5/+2
|
* [PATCH 12/57] cat/ls: rename arguments to argumentLeah Rowe2022-06-242-10/+10
| | | | It's only handling one argument.
* [PATCH 11/57] ls: Remove more unnecessary commentsLeah Rowe2022-06-241-11/+1
| | | | | | | The code Ferass originally wrote was very clear. The current code is still very clear. Do not document code in code, unless you really need to.
* [PATCH 10/57] ls: simplify code block for 'a' and 'A'Leah Rowe2022-06-241-7/+4
|
* [PATCH 09/57] ls: rename retval variable to statusLeah Rowe2022-06-241-3/+3
|
* [PATCH 08/57] add TODO: proper error codesLeah Rowe2022-06-245-0/+31
|
* [PATCH 07/57] ls: exit with non-zero return value when failingLeah Rowe2022-06-241-10/+9
| | | | Handling of arguments is generally more robust.
* [PATCH 06/57] ls: fix bug: output now given on e.g. ls -a -hLeah Rowe2022-06-241-3/+4
| | | | | | | | | | | | | The previous code checked for condition: if 2 arguments but 2nd argument starts with -, output contents of cwd. For example: ls -a However, say you did: ls -a -A Previously, this would output nothing at all. Now it works as intended.
* [PATCH 05/57] Remove further useless commentsLeah Rowe2022-06-241-17/+8
|
* [PATCH 04/57] Move usage instructions to specific functionsLeah Rowe2022-06-245-48/+48
|
* [PATCH 03/57] Remove superfluous commentsLeah Rowe2022-06-245-62/+44
|
* [PATCH 02/57] Make all code fit into 80 charactersLeah Rowe2022-06-245-27/+45
| | | | | | | | | | | | Nested if statements and so on have been condensed. If/else statements changed in a few places, to reduce the amount of nested code. Where tabs are literally entered into printf statements, use \t instead of actually typing a tab character. This is more correct. In general, make the code a bit more linear in how it reads.
* Make all code fit into 80 charactersLeah Rowe2022-06-241-0/+1
| | | | | | | | | | | | Nested if statements and so on have been condensed. If/else statements changed in a few places, to reduce the amount of nested code. Where tabs are literally entered into printf statements, use \t instead of actually typing a tab character. This is more correct. In general, make the code a bit more linear in how it reads.
* [PATCH 01/57] Re-factor the codebase, reduce nestingLeah Rowe2022-06-243-114/+109
|
* readme: add useful information and thank people who help meFerass 'Vitali64' EL HAFIDI2022-06-241-0/+61
| | | | Signed-off-by: Ferass 'Vitali64' EL HAFIDI <vitali64pmemail@protonmail.com>
* ls: exit when there's an invalid argumentFerass 'Vitali64' EL HAFIDI2022-06-191-0/+2
| | | | Signed-off-by: Ferass 'Vitali64' EL HAFIDI <vitali64pmemail@protonmail.com>
* ls: add -1 and update help textFerass 'Vitali64' EL HAFIDI2022-06-191-2/+5
| | | | Signed-off-by: Ferass 'Vitali64' EL HAFIDI <vitali64pmemail@protonmail.com>
* date: remove unnecessary stdio.hFerass 'Vitali64' EL HAFIDI2022-06-191-1/+0
| | | | Signed-off-by: Ferass 'Vitali64' EL HAFIDI <vitali64pmemail@protonmail.com>
* ls: fix a bug where 'ls -{argument}' gave no outputFerass 'Vitali64' EL HAFIDI2022-06-191-0/+3
| | | | Signed-off-by: Ferass 'Vitali64' EL HAFIDI <vitali64pmemail@protonmail.com>
* ls: handle conflicting argumentsFerass 'Vitali64' EL HAFIDI2022-06-191-11/+12
| | | | Signed-off-by: Ferass 'Vitali64' EL HAFIDI <vitali64pmemail@protonmail.com>
* readme: document new ls optionsFerass 'Vitali64' EL HAFIDI2022-06-191-0/+4
| | | | Signed-off-by: Ferass 'Vitali64' EL HAFIDI <vitali64pmemail@protonmail.com>
* ls: add help text about the 2 new optionsFerass 'Vitali64' EL HAFIDI2022-06-191-0/+2
| | | | Signed-off-by: Ferass 'Vitali64' EL HAFIDI <vitali64pmemail@protonmail.com>
* ls: fix handling of arguments, and add '-C' optionFerass 'Vitali64' EL HAFIDI2022-06-191-9/+48
| | | | Signed-off-by: Ferass 'Vitali64' EL HAFIDI <vitali64pmemail@protonmail.com>
* ls: add the '-A' optionFerass 'Vitali64' EL HAFIDI2022-06-191-1/+13
| | | | Signed-off-by: Ferass 'Vitali64' EL HAFIDI <vitali64pmemail@protonmail.com>
* date: implement `date`Ferass 'Vitali64' EL HAFIDI2022-06-184-1/+73
| | | | Signed-off-by: Ferass 'Vitali64' EL HAFIDI <vitali64pmemail@protonmail.com>
* fasesiab: typofixFerass 'Vitali64' EL HAFIDI2022-06-181-1/+0
| | | | Signed-off-by: Ferass 'Vitali64' EL HAFIDI <vitali64pmemail@protonmail.com>
* typofix: 'function' instead of 'macro'Ferass 'Vitali64' EL HAFIDI2022-06-172-2/+2
| | | | Signed-off-by: Ferass 'Vitali64' EL HAFIDI <vitali64pmemail@protonmail.com>
* readme: Add known bugs and reformatFerass 'Vitali64' EL HAFIDI2022-06-171-20/+32
| | | | Signed-off-by: Ferass 'Vitali64' EL HAFIDI <vitali64pmemail@protonmail.com>